Fedora 21 (Cinnamon)

Discussion in 'GNU/Linux' started by DarkLight, Jan 18, 2015.


  1. DarkLight

    DarkLight I self identify as a Blackhawk Attack Helicopter! Site Supporter

    Personally I'm not a big fan of the default Gnome desktop under any distribution of Linux. I am, for better or worse, used to a "Windows" type layout...start button, open apps along the bottom, etc. So I run Cinnamon.

    Upgrading from Fedora 20 to Fedora 21 is a little time consuming but for me was VERY straight forward, even using the Cinnamon "spin". The process below (specifically the command with "nonproduct") will work with any non-default, non-gnome desktop spin of Fedora.
    1. First and foremost, update your system for the current version. Using sudo (or as root) run:
      sudo yum update
      (Always, ALWAYS check what's going to be updated! It is NOT recommended to add the -y during an update or upgrade process unless you have already checked!)
    2. Install "fedup", the Fedora Ugrade utility:
      sudo yum -y install fedup
    3. Run fedup to upgrade to Fedora 21:
      sudo fedup --network 21 --product=nonproduct
      or, if you've downloaded the Fedora 21 ISO already you can pull the files from the local ISO. Doing a network install will get the most recent versions of all packages whereas an ISO install will most likely need to be updated.
      sudo fedup --iso /replace/with/full/path/to/ISO/file
      If you want to get rid of Cinnamon and move to gnome, execute:
      sudo fedup --network 21 (or --iso as above) --product=workstation
    4. This will download and stage all of the RPMs necessary to upgrade to Fedora 21. You will be prompted to reboot:
      reboot (or)
      shutdown -t 0 now -r (or)
      Select reboot from "Menu"
    5. Wait
    6. Seriously, wait
    7. No, for real, go get a coffee or build a shed or finish your Bachelor's degree.
    8. Okay, for me it took about 2 hours but that was because
      a) I'm running on an i3 with 4 GB memory, and;
      b) I'm running off of an external USB drive (drive is USB 3 but the computer only supports USB 2)
    9. Log in...which will take longer the first time because it's configuring your windowing system (Cinnamon in my case). It took about 5 minutes but probably due to USB 2.0 external disk.
    10. Bitmessage worked out of the box but during the RPM download phase it complained about Grive (Google Drive access tool) and Bitcoin-QT not being compatible. This is due to the fact that the fedup tool doesn't use your regular yum repositories, or didn't in my case. I had backups of the files though. Grive and Bitcoin needed to be updated.
    11. Bitcoin was fixed by re-adding the ringing liberty repository and simply updating the bitcoin version:
      sudo yum install http://linux.ringingliberty.com/bitcoin/f20/x86_64/bitcoin-release-1-6.noarch.rpm
      if you already had this installed but the repository is missing you can re-install it:
      sudo yum reinstall http://linux.ringingliberty.com/bitcoin/f20/x86_64/bitcoin-release-1-6.noarch.rpm
    12. Then run an update to get updates to any packages hosted by ringing liberty:
      sudo yum update
    13. After updating the files required for bitcoin, grive worked without issue.
    14. In my case that was it. Everything else I had installed worked fine, including running a copy of Microsoft Office under WINE.
     
  2. melbo

    melbo Hunter Gatherer Administrator Founding Member

    I was under the impression that f21 would support Bitcoin Core out of the box but not Bitmessage. Interesting that it works the opposite way.
    Thanks for the write up - will give this a try soon.
     
    sec_monkey likes this.
  3. DarkLight

    DarkLight I self identify as a Blackhawk Attack Helicopter! Site Supporter

    The missing pieces for bitcoin were libboost and...shoot, don't remember the other two but it looks like they were replaced by something else because they didn't get upgrade when I did a yum update after reinstalling the ringing liberty repo. It's entirely possible that the updated bitcoind, bitcoin-qt and bitcoin-cli didn't need those files (and now that I think of it, it didn't update the openssl package either). I'm wondering if bitmessage was still using the modified openssl and bitcoin just worked once it was updated. Now I have to spin up a virtual machine, do a scratch install and test...thanks. ;)
     
    melbo likes this.
  4. melbo

    melbo Hunter Gatherer Administrator Founding Member

    Did your f20 system make use of additional (non-official) repos?
    I think the issue I had when I gave it a quick attempt on a test system was that I still had active f20 rpmfusion (free & non-free) repos enabled.
     
    sec_monkey likes this.
  5. sec_monkey

    sec_monkey SM Security Administrator

    :eek: 2 hours ?

    took about 10 min on non-desktops

    [beer] :)
     
  6. melbo

    melbo Hunter Gatherer Administrator Founding Member

    I upgraded from f20 to f21 last night and it was painless.
    I use some 3rd party repos and they all worked except for dropbox although that sorted itself out on a post reboot yum update.

    First I installed fedup
    Code:
    sudo yum update
    sudo yum install fedup

    Updated the fedup repository:
    Code:
    yum update fedup fedora-release

    Started the upgrade to Workstation using network install:
    Code:
    sudo fedup --network 21 --product=workstation

    I waited for all packages to download and then rebooted into fedup where everything was installed. Rebooted again when this finished and ran a few clean up commands:
    Code:
    rpm --rebuilddb
    yum distro-sync --setopt=deltarpm=0
    sudo yum update

    rebooted one last time and called it a night.
    No issues at all.
     
    sec_monkey likes this.
  7. sec_monkey

    sec_monkey SM Security Administrator

    [applaud] [winkthumb]
     
  1. melbo
  2. melbo
  3. Witch Doctor 01
  4. melbo
  5. DarkLight
  6. kckndrgn
  7. melbo
  8. BTPost
  9. melbo
survivalmonkey SSL seal        survivalmonkey.com warrant canary
17282WuJHksJ9798f34razfKbPATqTq9E7